Fixing the 3 way fridge

After the first fridge set the van on fire I had to replace it. I swore blind I was not going to buy another Thetford so I found a well priced and not too old Dometic RM7400 3 way fridge on eBay. When I first installed it everything worked as it should but as time went on it became increasingly difficult to keep the pilot light on. After a bit of research and deduction I concluded (hoped) the issue lay with the thermocouple.

First things first, inspect the thermocouple, this means taking the fridge out of the nice space it’s in under the worktop as you can’t get to the right bits with ease from the vents.

The thermocouple sits in the burner at the bottom of the fridge chimney and looks like this once it’s been removed.

It’s the black bit to the right and should be well within the pilot light which comes from the jet you can see just below it, the white thing to the right is the Piezo ignition.

The thermocouple was covered in crud so I scraped all that off, cleaned up the jet area, refitted the whole thing and gave it a blast, hey presto it worked first time..

A couple of trips later and the fridge again failed to light so at the earliest opportunity I took everything apart again and found I had not tightened the torx bolt tight enough so the thermocouple had moved out of place.

I realigned the thermocouple and tightened up the torx bolt so now it shouldn’t go anywhere, next time we were out I tried the fridge again and it fired first time. I’ve also learnt that when we stop to park up, switch the fridge to gas, leave it for about 10 mins and then light it, works first time every time. Don’t know why but if I try to light it any sooner than the 10 mins I give it the thing is a pain to light